Sitecore Connector

Upgrading to Version 1.3x

We made some key changes to the Sitecore Connector in version 1.3 so to upgrade from an earlier version, you will need to follow some additional steps.

Before Installation

  1. In the Sitecore Content Editor, navigate to System > Modules > Smartling Connector and copy the Callback Token value. Store it somewhere safe.
  2. Generate Smartling API v2 Credentials for your Sitecore project. Follow these instructions and save your User Identifier and Token Secret.
  3. You need to update your database schema for version 1.3. Connect to your database via your preferred tool and run the following script:

    SQL

    SET QUOTED_IDENTIFIER ON
    GO
    ALTER TABLE [dbo].[TranslationQueue] ADD [LastModified] [datetime]
    GO
    UPDATE [dbo].[TranslationQueue]
    SET [LastModified]=0
    GO
    ALTER TABLE [dbo].[TranslationQueue] ALTER COLUMN [LastModified] [datetime] NOT NULL
    GO

If you don’t know your database endpoint, you can find it in your Sitecore configuration at /Website/App_Config/ConnectionStrings.config. The database endpoint is in the SitecoreLocalization entry.

Install

You can now upload and install the new 1.3 packages. Be sure to install all packages before you continue with the configuration.

After Installation

  1. Open the Sitecore Content Editor, go to Systems > Settings > Validation Rules > Field Rules > System and delete the SitecoreLocalizationApiKey entry.
    after_installation.png
  2. Update your Smartling Configuration profiles.
    • Go to System > Modules > Smartling Connector > Context and update your Server URL.
      update2.png
    • Go to each of your Profiles under System > Modules > Smartling Connector > Profiles and update your project details, including your User Identifier and Token Secret.
      default_content.png
  3. Go to System > Modules > Smartling Connector > Callback and paste in your saved Callback Token value.
    callback.png

The Sitecore connector should be ready to continue translation.

Was this article helpful?